[riot-notifications] [RIOT-OS/RIOT] Kconfig: add modules to test on native (#15421)

Francisco notifications at github.com
Tue Nov 17 11:36:48 CET 2020


> Check that the dependencies are correctly modelled

I had a close look, everything seems ok.

> Peripheral test applications should still work as usual when using TEST_KCONFIG=1

I compared the binaries on some applications they are the same

> Non-supported applications should explain the missing features/modules.

```
TEST_KCONFIG=1 BOARD=native make -C tests/periph_rtt/ clean all
make: Entering directory '/home/francisco/workspace/RIOT/tests/periph_rtt'
=== [ATTENTION] Testing Kconfig dependency modelling ===
[genconfig.py]:ERROR-=> The module MODULE_PERIPH_RTT could not be set to y.
[genconfig.py]:ERROR-   Check the following unmet dependencies: HAS_PERIPH_RTT (=n)

...
...

TEST_KCONFIG=1 BOARD=native make -C tests/periph_backup_ram
make: Entering directory '/home/francisco/workspace/RIOT/tests/periph_backup_ram'
=== [ATTENTION] Testing Kconfig dependency modelling ===
[genconfig.py]:ERROR-=> The application symbol (APPLICATION) is not set.
[genconfig.py]:ERROR-   Check that the symbol defaults to 'y'.
[genconfig.py]:ERROR-   Check the following unmet dependencies: HAS_BACKUP_RAM (=n)
```

> Usage of Kconfig as usual (without TEST_KCONFIG=1) should still work normally

The only issue I found seems unrelated to this PR https://github.com/RIOT-OS/RIOT/pull/15421#issuecomment-728837002.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/RIOT-OS/RIOT/pull/15421#issuecomment-728841482
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.riot-os.org/pipermail/notifications/attachments/20201117/e38e3a4e/attachment.htm>


More information about the notifications mailing list