[riot-notifications] [RIOT-OS/RIOT] cpu/stm32/kconfig: fix rtt/rtc error symbol (#15834)

Alexandre Abadie notifications at github.com
Fri Jan 22 16:02:38 CET 2021


> It should have a defined value, which is the string indicating the error.

I tried with nucleo-l073rz and iotlab-m3 and I can find the `ERROR_MODULE_CONFLICT` symbol for both and in both cases it's empty (`ERROR_MODULE_CONFLICT(=)`. I doesn't seem to be correct, I would expect the value set to 1 for iotlab-m3.

I tried `TEST_KCONFIG=1 make BOARD=iotlab-m3 -C examples/hello-world menuconfig` with the following diff:

```diff
diff --git a/examples/hello-world/Makefile b/examples/hello-world/Makefile
index 258d8e9baf..a860204823 100644
--- a/examples/hello-world/Makefile
+++ b/examples/hello-world/Makefile
@@ -12,6 +12,8 @@ RIOTBASE ?= $(CURDIR)/../..
 # development process:
 DEVELHELP ?= 1
 
+FEATURES_REQUIRED = periph_rtt periph_rtc
+
 # Change this to 0 show compiler invocation lines by default:
 QUIET ?= 1
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/RIOT-OS/RIOT/pull/15834#issuecomment-765464841
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.riot-os.org/pipermail/notifications/attachments/20210122/903e76ad/attachment.htm>


More information about the notifications mailing list