[riot-notifications] [RIOT-OS/RIOT] sys/crypto: Enable support for AES-192, AES-256 (#16183)

Leandro Lanzieri notifications at github.com
Mon May 3 10:45:10 CEST 2021


@leandrolanzieri commented on this pull request.

I added one more comment regarding the dependency resolution. Otherwise it looks good. Feel free to squash after applying the fix @Ollrogge 

> +ifneq (,$(filter crypto_aes_unroll,$(USEMODULE)))
+  USEMODULE += crypto_aes_128
+endif
+
+ifneq (,$(filter crypto_aes_precalculated,$(USEMODULE)))
+  USEMODULE += crypto_aes_128

I don't think this dependency is actually needed. This is forcing to have AES 128 whenever the user wants to unroll loops or use the pre-calculated tables. So I would drop this. If it is a concern that these modules are used without any `crypto_aes_%` module selected, this could be checked in  `sys/crypto/Makefile.include`.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/RIOT-OS/RIOT/pull/16183#pullrequestreview-650148149
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.riot-os.org/pipermail/notifications/attachments/20210503/12bd1d3e/attachment.htm>


More information about the notifications mailing list