[riot-notifications] [RIOT-OS/RIOT] gnrc: deprecate gnrc_netdev_default, use netdev_default instead (#16744)

Martine Lenders notifications at github.com
Mon Sep 6 11:07:13 CEST 2021


@miri64 requested changes on this pull request.



>  # use a minimal GNRC configuration
-USEMODULE += gnrc_netdev_default
+USEMODULE += netdev_default

Given the comment, I think the line should be moved up. But I don't believe the module is needed at all, as `nrfmin` is included above.

> @@ -7,7 +7,7 @@ USEMODULE += shell_commands
 USEMODULE += ps
 
 # Include GNRC and RPL
-USEMODULE += gnrc_netdev_default
+USEMODULE += netdev_default

Same here. Not a GNRC module anymore + I am not sure it is needed or should be replaced by `nimble` directly.

> @@ -7,7 +7,7 @@ USEMODULE += shell_commands
 USEMODULE += ps
 
 # Include GNRC and RPL
-USEMODULE += gnrc_netdev_default
+USEMODULE += netdev_default

And finally here: Not a GNRC module anymore + I am not sure it is needed or should be replaced by `nimble` directly.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/RIOT-OS/RIOT/pull/16744#pullrequestreview-746997165
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.riot-os.org/pipermail/notifications/attachments/20210906/49c561b0/attachment.htm>


More information about the notifications mailing list