[riot-notifications] [RIOT-OS/RIOT] build system: add machine-readable RIOT_VERSION_CODE macro (#16765)

Martine Lenders notifications at github.com
Mon Sep 20 15:50:00 CEST 2021


I am starting to think having a valid value for "in-between" releases does not make much sense and will lead to confusion (with @kfessel's proposal, if I checkout some old branch of mine, that is in-between 2021.04 and 2021.07, it will still think it is larger than 2021.07, potentially breaking my API usage, if I rely on `RIOT_VERSION_CODE` for confusing reasons... Is there a way maybe to have the comparison be ignored or alternatively fail hard for in-between versions?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/RIOT-OS/RIOT/pull/16765#issuecomment-922945735
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.riot-os.org/pipermail/notifications/attachments/20210920/c4879b0f/attachment.htm>


More information about the notifications mailing list