<p><a class="user-mention" data-hovercard-type="user" data-hovercard-url="/hovercards?user_id=1375137" data-octo-click="hovercard-link-click" data-octo-dimensions="link_type:self" href="https://github.com/aabadie">@aabadie</a> Thanks for the SAUL tips, it is now fixed.</p>
<blockquote>
<p>Also the tests/buttons doesn't work. Maybe the exti array needs an update (haven't checked the datasheet). Or there is something else with the peripheral driver ?</p>
</blockquote>
<p>I forget something important for this <del>damned</del> SAML11 MCU in the GPIO driver, the EXTI array should be fine, I looked at the datasheet.<br>
tests/buttons should now works for SAML11 (it was working but for SAML10 only).</p>

<p style="font-size:small;-webkit-text-size-adjust:none;color:#666;">—<br />You are receiving this because you are subscribed to this thread.<br />Reply to this email directly, <a href="https://github.com/RIOT-OS/RIOT/pull/10653#issuecomment-454824768">view it on GitHub</a>, or <a href="https://github.com/notifications/unsubscribe-auth/AEn7YECvNnXpgDF8WMXc7W4A3CgEdCXUks5vD0fTgaJpZM4ZgjGv">mute the thread</a>.<img src="https://github.com/notifications/beacon/AEn7YMxGcCcRk50aQRBUnHUY4b_656Itks5vD0fTgaJpZM4ZgjGv.gif" height="1" width="1" alt="" /></p>
<script type="application/json" data-scope="inboxmarkup">{"api_version":"1.0","publisher":{"api_key":"05dde50f1d1a384dd78767c55493e4bb","name":"GitHub"},"entity":{"external_key":"github/RIOT-OS/RIOT","title":"RIOT-OS/RIOT","subtitle":"GitHub repository","main_image_url":"https://github.githubassets.com/images/email/message_cards/header.png","avatar_image_url":"https://github.githubassets.com/images/email/message_cards/avatar.png","action":{"name":"Open in GitHub","url":"https://github.com/RIOT-OS/RIOT"}},"updates":{"snippets":[{"icon":"PERSON","message":"@dylad in #10653: @aabadie Thanks for the SAUL tips, it is now fixed.\r\n\r\n\u003e Also the tests/buttons doesn't work. Maybe the exti array needs an update (haven't checked the datasheet). Or there is something else with the peripheral driver ?\r\n\r\nI forget something important for this ~~damned~~ SAML11 MCU in the GPIO driver, the EXTI array should be fine, I looked at the datasheet.\r\ntests/buttons should now works for SAML11 (it was working but for SAML10 only).\r\n"}],"action":{"name":"View Pull Request","url":"https://github.com/RIOT-OS/RIOT/pull/10653#issuecomment-454824768"}}}</script>
<script type="application/ld+json">[
{
"@context": "http://schema.org",
"@type": "EmailMessage",
"potentialAction": {
"@type": "ViewAction",
"target": "https://github.com/RIOT-OS/RIOT/pull/10653#issuecomment-454824768",
"url": "https://github.com/RIOT-OS/RIOT/pull/10653#issuecomment-454824768",
"name": "View Pull Request"
},
"description": "View this Pull Request on GitHub",
"publisher": {
"@type": "Organization",
"name": "GitHub",
"url": "https://github.com"
}
}
]</script>