<p><a class="user-mention" data-hovercard-type="user" data-hovercard-url="/hovercards?user_id=1301112" data-octo-click="hovercard-link-click" data-octo-dimensions="link_type:self" href="https://github.com/benpicco">@benpicco</a> <a class="user-mention" data-hovercard-type="user" data-hovercard-url="/hovercards?user_id=241401" data-octo-click="hovercard-link-click" data-octo-dimensions="link_type:self" href="https://github.com/cladmi">@cladmi</a> Sorry when I'm answering too late or not at all these days. I'm on vacation for hiking all the day and have often only very limited internet access. Furthermore, I don't have the hardware with me to check all the problems.</p>
<p>Unfortunately, the issue is a bit more complicated. The ESP8266 toolchain uses <a href="https://github.com/pfalcon/esp-open-sdk.git">esp-open-sdk</a> which already includes <code>esptool.py</code>, independent on whether you <a href="https://doc.riot-os.org/group__cpu__esp8266.html#esp8266_manual_toolchain_installation" rel="nofollow">compile it by yourself</a> or you use the <a href="https://doc.riot-os.org/group__cpu__esp8266.html#esp8266_precompiled_toolchain" rel="nofollow">precompiled version</a>. The version of this <code>esptool.py</code> is not 2.5 but version 1.2. That's why it doesn't understand the new arguments. As documented for ESP32, <code>esptool.py</code> version 2.4 is required to understand the new arguments.</p>
<p>I could prepare a special version of the toolchain which overwrites the included <code>esptool.py</code> with a newer version. But if the user compiles the toolchain by himself, he would also have to install <code>esptool.py</code> with <code>pip install esptool</code>. Furthermore, he would have to ensure that the newer version is found in his <code>PATH</code> before the version of <code>esptool.py</code> provided by the <code>esp-open-sdk</code>.</p>
<p><a class="user-mention" data-hovercard-type="user" data-hovercard-url="/hovercards?user_id=241401" data-octo-click="hovercard-link-click" data-octo-dimensions="link_type:self" href="https://github.com/cladmi">@cladmi</a> Thank you for PR <a class="issue-link js-issue-link" data-error-text="Failed to load issue title" data-id="494074852" data-permission-text="Issue title is private" data-url="https://github.com/RIOT-OS/RIOT/issues/12252" data-hovercard-type="pull_request" data-hovercard-url="/RIOT-OS/RIOT/pull/12252/hovercard" href="https://github.com/RIOT-OS/RIOT/pull/12252">#12252</a> and reverting the change for the moment.</p>

<p style="font-size:small;-webkit-text-size-adjust:none;color:#666;">—<br />You are receiving this because you are subscribed to this thread.<br />Reply to this email directly, <a href="https://github.com/RIOT-OS/RIOT/issues/12247?email_source=notifications&email_token=ABE7WYGLMRXTRHDI2JYDE7TQJ65ZPA5CNFSM4IXA7W2KYY3PNVWWK3TUL52HS4DFVREXG43VMVBW63LNMVXHJKTDN5WW2ZLOORPWSZGOD6Z33JI#issuecomment-531873189">view it on GitHub</a>, or <a href="https://github.com/notifications/unsubscribe-auth/ABE7WYAUW7G7VUY6WTLZW6LQJ65ZPANCNFSM4IXA7W2A">mute the thread</a>.<img src="https://github.com/notifications/beacon/ABE7WYAOLTL4LYOJD3ZSDVLQJ65ZPA5CNFSM4IXA7W2KYY3PNVWWK3TUL52HS4DFVREXG43VMVBW63LNMVXHJKTDN5WW2ZLOORPWSZGOD6Z33JI.gif" height="1" width="1" alt="" /></p>
<script type="application/ld+json">[
{
"@context": "http://schema.org",
"@type": "EmailMessage",
"potentialAction": {
"@type": "ViewAction",
"target": "https://github.com/RIOT-OS/RIOT/issues/12247?email_source=notifications\u0026email_token=ABE7WYGLMRXTRHDI2JYDE7TQJ65ZPA5CNFSM4IXA7W2KYY3PNVWWK3TUL52HS4DFVREXG43VMVBW63LNMVXHJKTDN5WW2ZLOORPWSZGOD6Z33JI#issuecomment-531873189",
"url": "https://github.com/RIOT-OS/RIOT/issues/12247?email_source=notifications\u0026email_token=ABE7WYGLMRXTRHDI2JYDE7TQJ65ZPA5CNFSM4IXA7W2KYY3PNVWWK3TUL52HS4DFVREXG43VMVBW63LNMVXHJKTDN5WW2ZLOORPWSZGOD6Z33JI#issuecomment-531873189",
"name": "View Issue"
},
"description": "View this Issue on GitHub",
"publisher": {
"@type": "Organization",
"name": "GitHub",
"url": "https://github.com"
}
}
]</script>