[riot-users] Stm32f4 Discovery Shell UART not working

Peter Kietzmann peter.kietzmann at haw-hamburg.de
Thu Oct 30 16:33:14 CET 2014


Am 30.10.2014 um 16:16 schrieb Ludwig Ortmann:
> Hi Joachim,
>
> On Thu, Oct 30, 2014 at 04:07:00PM +0100, Joachim wrote:
>> my first posting :)
> Welcome =)
Welcome also from my part :-) ,
>
> Do you have any particular project you want to use RIOT in?
>
>> On my Stm32f4 Discovery it starts, I can see the startup messages after Reset. But it seems, that inputs from the Terminal are not working. There is no reaction on it.
>>
>> I found on gitgub a posting from Hauke. He had the same problem but later not and I do not why.
>>
>> May be Hauke or another one has a hint for me? I checked already my HW, it seems to be ok.
> Might be something to do with your compiler - did you check the wiki?

Maybe you just did not connect your tty/USB adapter correctly? If you 
compare [1] you can see the predefined pin mapping is: PA2 = UART_0_TX 
and PA3 = UART_0_RX. Also [2] may be of interest for getting started.
I compiled the shell example (in RIOT/tests/shell) with gcc-arm-embedded 
and connected my adapter like described above. Then I used the pyterm 
tool (in RIOT/dist/tools/pyterm) and terminal IOs were working correctly.
>
> Cheers, Ludwig

Cheers,
Peter

[1] https://github.com/RIOT-OS/RIOT/wiki/Board:-STM32F4discovery
[2] 
https://github.com/RIOT-OS/RIOT/wiki/Getting-started-with-STM32F%5B0|3|4%5Ddiscovery-boards
> _______________________________________________
> users mailing list
> users at riot-os.org
> http://lists.riot-os.org/mailman/listinfo/users



More information about the users mailing list