[riot-users] Ping from tap interface of one RIOT instance to another dont work.

Cenk G√ľndogan cenk.guendogan at fu-berlin.de
Tue Dec 22 21:45:55 CET 2015


Hello Rikhu,

Can you try creating the tap interfaces with the tapsetup script
located in RIOT/dist/tools/tapsetup/tapsetup ?

This tapsetup script will create an interface (br0) that serves as a bridge
between tap0 and tap1 (and other taps created by the tapsetup script).

Thank you for pointing out this issue, I will address this in the tutorial.

Best,
Cenk

On 22.12.2015 21:39, Rikhu Prasad wrote:
> Hi,
>
> I followed the following tutorial to get used to developing 
> application in RIOT.
>
> https://github.com/cgundogan/RIOT-Tutorial/
>
> As per the below, I have configured one instance of RIOT to tap0 and 
> another instance to tap1. and try to ping between 2 instances and this 
> does not work. Am I missing something? Please advice.
>
> 1. Running RIOT on Native -> 8th point..
>
> _*RIOT  (Instance 1):*_
> _
> _
> ifconfig
> Iface  4   HWaddr: 22:a4:56:14:8a:61
>            MTU:1280  HL:64
>            Source address length: 6
>            Link type: wired
>            inet6 addr: ff02::1/128  scope: local [multicast]
>            inet6 addr: fe80::20a4:56ff:fe14:8a61/64  scope: local
>            inet6 addr: ff02::1:ff14:8a61/128  scope: local [multicast]
>            inet6 addr: ff02::2/128  scope: local [multicast]
>
> *RIOT (Instance 2) : *
> *
> *
> ifconfig
> Iface  4   HWaddr: ca:ec:7d:fd:db:d0
>            MTU:1280  HL:64
>            Source address length: 6
>            Link type: wired
>            inet6 addr: ff02::1/128  scope: local [multicast]
>            inet6 addr: fe80::c8ec:7dff:fefd:dbd0/64  scope: local
>            inet6 addr: ff02::1:fffd:dbd0/128  scope: local [multicast]
>            inet6 addr: ff02::2/128  scope: local [multicast]
>
> *_I try to ping RIOT1 from RIOT2 : _*
> *_
> _*
> ping6 fe80::20a4:56ff:fe14:8a61
> ping timeout
> ping timeout
> ping timeout
> --- fe80::20a4:56ff:fe14:8a61 ping statistics ---
> 3 packets transmitted, 0 received, 100% packet loss
>
> I try to ping RIOT instance 1 from instance 2 and dont work. I tried 
> various other means like mentioning tap interface in ping command, 
> still, don't work.
>
>
>
> -Rik
>
>
> _______________________________________________
> users mailing list
> users at riot-os.org
> https://lists.riot-os.org/mailman/listinfo/users

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.riot-os.org/pipermail/users/attachments/20151222/11aaea7c/attachment.html>


More information about the users mailing list