[riot-users] run RIOT Tutorial on stm32f4dicovery

Zhongwei Yao ashi08104 at gmail.com
Sun Jan 11 04:14:51 CET 2015


Hi, all,
I'm trying to run the RIOT Tutorial[1] on stm32f4dicovery. But I find the
sixlowapp[2] couldn't be compile for stm32f4dicovery board. It gives error:

There are unsatisfied feature requirements: transceiver

EXPECT ERRORS!

And it seems there is no transceiver module on stm32f4dicovery yet. If I
want to add transceiver module on stm32f4dicovery and enable the sixlowapp
on stm32f4dicovery, what I should do?

And by the way, I have some cc2420 nodes in hand. After some search, I find
cc2420 already has driver in RIOT. But it seems not support
stm32f4dicovery. If I want to run sixlowapp on stm32f4dicovery with cc2420,
what should I do? Is this post[3] still applicable?

And another related question is: if I want to run libcoap on
stm32f4dicovery with cc2420 in the feature, am I on the right way to this
objective?

Thank a lot!
Zhongwei

[1]:http://www.codeproject.com/Articles/840499/RIOT-Tutorial
[2]:https://github.com/RIOT-OS/applications
[3]:http://lists.riot-os.org/pipermail/users/2014-November/000187.html
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.riot-os.org/pipermail/users/attachments/20150111/e26687ff/attachment.html>


More information about the users mailing list