[riot-users] No hwtimer left

Laura Jane Martinus martinus.laura at gmail.com
Mon Jul 13 11:46:45 CEST 2015


This causes undefined references in files such as main.c auto_init.c
sc_ltc4150.c

On 13 July 2015 at 11:22, Kaspar Schleiser <kaspar at schleiser.de> wrote:

> Hey,
>
> On 07/13/15 10:46, Laura Jane Martinus wrote:
> > http://www.codeproject.com/Articles/840499/RIOT-Tutorial . When I type
> > "make all term" at the default examples I receive the error
> >
> > No hwtimer left
> > RIOT/examles/default/bin/native/default/elf: ltc4150_enable_int:
> hwtimer_set
> > make: *** [term] Error 1
> >
> > Do you have any suggestions on how to correct this?
> Try to comment out these lines from the Makefile
> (examples/default/Makefile) and recompile:
>
> (they're lines 53 to 56 in master)
>
>  53 ifneq (,$(filter native,$(BOARD)))
>  54 ›   USEMODULE += ltc4150
>  55 ›   USEMODULE += random
>  56 endif
>
> This will disable the emulation of an energy monitor chip, which you
> probably don't need.
>
> The problem is cause by a recent switch to native that makes it
> effectively only have one "hwtimer" which is being used up be the
> software timer multiplexer ("vtimer"), and ltc4150's native driver
> hard-exiting when it cannot get a timer.
>
> Kaspar
> _______________________________________________
> users mailing list
> users at riot-os.org
> http://lists.riot-os.org/mailman/listinfo/users
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.riot-os.org/pipermail/users/attachments/20150713/c36ec74c/attachment.html>


More information about the users mailing list