[riot-users] Send UDP packet by Xbee

Martine Lenders mail at martine-lenders.eu
Sun Feb 18 17:52:03 CET 2018


Hi Tiago,

can you tell us on which git revision you are on? There used to be a bug in
xbee, pretty much as you described, but that should be fixed as of the
latest release (and in current master).

Cheers,
Martine

2018-02-18 11:47 GMT+01:00 tiago carvalho <tiago_carvalho_1 at hotmail.com>:

> Hey guys,
>
>
>
> I’m trying to send a UDP packet but the xbee module is not invoked.
>
>
>
> I’m using a mbed lpc1768 board with a Xbee radio and the ‘ps’ output is
> the following:
>
>
>
> > ps
>
>         pid | name                 | state    Q | pri | stack ( used) |
> base       | current
>
>           - | isr_stack            | -        - |   - |   512 (  336) |
> 0x100000c8 | 0x10000290
>
>           1 | idle                 | pending  Q |  15 |   256 (  128) |
> 0x1000050c | 0x1000058c
>
>           2 | main                 | running  Q |   7 |  1536 (  732) |
> 0x1000060c | 0x10000a7c
>
>           3 | pktdump              | bl rx    _ |   6 |  1536 (  236) |
> 0x10001d58 | 0x1000226c
>
>           4 | 6lo                  | bl rx    _ |   3 |  1024 (  268) |
> 0x10002358 | 0x1000264c
>
>           5 | ipv6                 | bl rx    _ |   4 |  1024 (  292) |
> 0x100015f0 | 0x100018cc
>
>           6 | udp                  | bl rx    _ |   5 |  1024 (  484) |
> 0x100028e4 | 0x10002bdc
>
>           7 | coap                 | bl mbox  _ |   6 |  1024 (  584) |
> 0x100011ec | 0x100013a4
>
>           8 | xbee                 | bl rx    _ |   2 |  1024 (  540) |
> 0x10000c6c | 0x10000f74
>
>             | SUM                  |            |     |  8960 ( 3600)
>
>
>
> When I try to send a UDP packet using ‘gnrc_netapi_dispatch_send(GNRC_NETTYPE_UDP,
> GNRC_NETREG_DEMUX_CTX_ALL, ip)’ the invoked pids are, by this order, 6
> (udp) and 5 (ipv6). After this, the packet is not transmitted.
>
>
>
> Note: Xbee module is working (it transmits information if called directly
> by UART).
>
>
>
> Thanks in advance,
>
> Tiago Carvalho
>
> _______________________________________________
> users mailing list
> users at riot-os.org
> https://lists.riot-os.org/mailman/listinfo/users
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.riot-os.org/pipermail/users/attachments/20180218/acb1937e/attachment.html>


More information about the users mailing list