[riot-users] I cannot get an address from the BR

smlng s at mlng.net
Wed Jan 17 09:23:06 CET 2018


Hello Iliyan,


great to hear you're working with RIOT + LoWPAN radios! As you already have a basic setup with
link-local addresses working, the (most) tricky parts are done. To get started with ULAs or real
public/global IP(v6) addresses you could setup RADVD on the RasPi. RADVD is a router advertisement
daemon, which will answer Router-Solications (RS) by RIOT nodes. RADVD can announce an IPv6
prefix (ULA or public) to the nodes, which than can autoconfigure an IPv6 address.

Please checkout the following repository and the guides in its wiki, for further infos:

- https://github.com/RIOT-Makers/wpan-raspbian
- https://github.com/RIOT-Makers/wpan-raspbian/wiki

Best,
  Sebastian


> On 17. Jan 2018, at 01:32, Iliyan Stoyanov <ilf.stoyanov at gmail.com> wrote:
> 
> Hello,
> 
> 
> I have few bluepills with at86rf212b transceivers (my design), trying to get address from a RPi BR with another at86rf212b transceiver (OpenWRT).
> 
> When I put all devices in the same PAN i can ping the link-local addresses and they work very well, unfortunately the RIOT nodes do not solicit Public or ULA addresses. I can not test this with RIOT as BR, as I don't have a device that can fit the BR example app (my Bluepills are all 64kb, not 128kb).
> 
> I researched the open issues on github and saw that there is a similar issue with Xbee and OpenLabs' transceiver. Is my issue similar and if so, can someone point me in the right direction of fixing it, or is this unrelated and should I open a separate issue on github?
> 
> --ilf
> _______________________________________________
> users mailing list
> users at riot-os.org
> https://lists.riot-os.org/mailman/listinfo/users



Sebastian

[mail]: s at mlng.net
[code]: https://github.com/smlng



More information about the users mailing list