[riot-users] Use POSIX pthreads in pkg

Philipp Blum philipp-blum at jakiku.de
Wed Oct 24 08:31:01 CEST 2018


 

Hi Kaspar, 

Sorry, I didn't pushed the change ^^ So, updated the branch. Still this
branch:
https://github.com/Citrullin/RIOT/tree/iota_new_implementation/examples/iota_transaction_light


best regards 

Philipp 

Am 2018-10-23 19:06, schrieb Philipp Blum: 

> Hi Kaspar, 
> 
> I am using Ubuntu 16.04.3. 
> 
> as requested, it produces the following output: 
> 
> Installed compiler toolchains 
> -----------------------------
> native gcc: gcc (Ubuntu 5.4.0-6ubuntu1~16.04.10) 5.4.0 20160609
> arm-none-eabi-gcc: arm-none-eabi-gcc (GNU Tools for Arm Embedded Processors 7-2018-q3-update) 7.3.1 20180622 (release) [ARM/embedded-7-branch revision 261907]
> avr-gcc: avr-gcc (GCC) 4.9.2
> mips-mti-elf-gcc: missing
> msp430-gcc: missing
> riscv-none-embed-gcc: missing
> clang: clang version 3.8.0-2ubuntu4 (tags/RELEASE_380/final)
> 
> Installed compiler libs
> -----------------------
> arm-none-eabi-newlib: "3.0.0"
> mips-mti-elf-newlib: missing
> riscv-none-embed-newlib: missing
> avr-libc: "1.8.0svn" ("20111229")
> 
> Installed development tools
> ---------------------------
> cmake: cmake version 3.11.0-rc1
> cppcheck: missing
> doxygen: missing
> flake8: missing
> git: git version 2.7.4
> coccinelle: missing 
> 
> best regards 
> 
> Philipp 
> 
> Am 2018-10-23 12:06, schrieb Kaspar Schleiser: 
> Hi Philip,
> 
> On 10/22/18 11:02 PM, Philipp Blum wrote: yes, I pushed it to my repo:
> https://github.com/Citrullin/RIOT/tree/iota_new_implementation/examples/iota_transaction_light
> 
> That's the application where I use this package. I used make to compile
> it for my bluepill. 
> I quickly tried it, it compiles fine here.
> 
> What Host OS and toolchain are you using?
> What's the output of "dist/tools/ci/print_toolchain_versions.sh"?
> 
> Kaspar
> 
> Am 2018-10-22 11:15, schrieb Kaspar Schleiser:
> 
> Hi Philipp,
> 
> On 10/21/18 8:21 PM, Philipp Blum wrote: I have a library which includes <pthreads.h>.
> 
> I got another file named Makefile.dep, where I placed my dependencies:
> 
> USEMODULE += posix
> USEMODULE += pthread 
> That *should* do it. Can you point to the actual github repo?
> 
> Kaspar

_______________________________________________
users mailing list
users at riot-os.org
https://lists.riot-os.org/mailman/listinfo/users 

  
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.riot-os.org/pipermail/users/attachments/20181024/5233dc13/attachment.html>


More information about the users mailing list