[riot-users] Deprecation of oonf_api

Benjamin Valentin benjamin.valentin at ml-pa.com
Tue Oct 8 14:34:45 CEST 2019


Hello,

I propose to deprecate the oonf_api package [1]. The package provides a 
framework to implement MANET protocols and is used by the NHDP 
implementation. This one however is also marked as deprecated and is 
scheduled to be removed after the 2020.04 release.

The package has not been updated in the 6 years since I added it, it 
still points to version 0.3.0 from 2013. And while the tests have been 
ported to RIOT, they were never integrated into CI.

This all indicates that the package doesn't have any users, so instead 
of bringing it up to date with the current times, we might as well just 
remove it.

If this is not the case and you still have use for this package, please 
speak up!

Best regards,

Benjamin

[1] https://github.com/RIOT-OS/RIOT/pull/12190



More information about the users mailing list