<div dir="ltr"><div><div><div><div>Hi Aurelién,<br><br></div>I'm currently running some experiments in a nucleo-L073RZ, calling xtimer_usleep with small random values, just to check if I can reproduce the issue.<br></div>On the other side, is the same issue happening if you increase the XTIMER_BACKOFF?<br><br></div>Cheers,<br></div>José<br></div><br><div class="gmail_quote"><div dir="ltr">Le lun. 15 janv. 2018 à 21:59, Aurélien Fillau <<a href="mailto:aurelien.fillau@gmail.com">aurelien.fillau@gmail.com</a>> a écrit :<br></div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div dir="ltr"><div dir="auto"><div>Hi,</div><div dir="auto"><br></div><div dir="auto">Thank you for your replies and i apologize for the delay in responding.</div><div dir="auto">We are working on custom boards now that embeds a STM32L073CZT6 CPU. We have started the project with a nucleo-l073rz board (STM32L073RZT6), and i think it can be easily reproduced on this board.</div><div dir="auto"><span style="font-size:12.8px">xtimer_usleep() </span>is called from thread context (not from an isr context).</div><div dir="auto">I didn't try to change <span style="font-size:12.8px">XTIMER_BACKOFF </span>because i have stabilized it to faced another issue (Indeed, <span style="font-size:12.8px">xtimer_usleep() was sleeping my task forever if </span><span style="font-size:12.8px">XTIMER_BACKOFF  was too small</span><span style="font-size:12.8px">)</span>.</div><div dir="auto">This "blocking while" can occur at startup or after 24 hours or even after a longer period of time, or even never on some boards, that's why it is not easily reproducible.</div><div dir="auto"><br></div><div dir="auto">Regards,</div><div dir="auto"><br></div><div dir="auto">Aurélien</div><div dir="auto"><div class="gmail_extra" dir="auto"><br><div class="gmail_quote"></div></div></div></div></div><div dir="ltr"><div dir="auto"><div dir="auto"><div class="gmail_extra" dir="auto"><div class="gmail_quote">Le 15 janv. 2018 10:56, "Jose Alamos" <<a href="mailto:jialamos@uc.cl" target="_blank">jialamos@uc.cl</a>> a écrit :<br type="attribution"></div></div></div></div></div><div dir="ltr"><div dir="auto"><div dir="auto"><div class="gmail_extra" dir="auto"><div class="gmail_quote"><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex"><div dir="ltr"><div><div><div>Hi Aurélien:<br><br></div>Could you give us more information about your platform? (e.g CPU model, etc). <br></div><div>Are you getting the same results with different values of XTIMER_BACKOFF?<br></div><br></div><div>Cheers<br><br></div>José<br></div>
<br></blockquote></div></div></div></div></div><div dir="ltr"><div dir="auto"><div dir="auto"><div class="gmail_extra" dir="auto"><div class="gmail_quote"><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex">_______________________________________________<br>
users mailing list<br>
<a href="mailto:users@riot-os.org" target="_blank">users@riot-os.org</a><br>
<a href="https://lists.riot-os.org/mailman/listinfo/users" rel="noreferrer" target="_blank">https://lists.riot-os.org/mailman/listinfo/users</a><br>
<br></blockquote></div></div>
</div></div>
</div>
</blockquote></div>