<html>
  <head>
    <meta http-equiv="Content-Type" content="text/html;
      charset=ISO-8859-7">
  </head>
  <body text="#000000" bgcolor="#FFFFFF">
    <p>Hey,</p>
    <p><br>
    </p>
    <p>this error comes from the initialisation of the gpio pins [0].<br>
    </p>
    <p>You can find that the default params of the srf04 [1] pins are
      set to GPIO_PIN(0,13) and GPIO_PIN(0,14). Those are kind of
      logical pins - NOT pins 13 and 14 on your hardware - and it seems
      RIOT does not provide these logical pins on the arduino-atmega
      boards as given in the boards config [2] (these are definitions
      for a family of arduino boards, one of them is the uno).</p>
    <p>You will have to set up your own params, to change the GPIO Pins
      to some available pins from [2].</p>
    <p><br>
    </p>
    <p>best<br>
      Semjon<br>
    </p>
    <p><br>
      [0]
      <a class="moz-txt-link-freetext" href="https://github.com/RIOT-OS/RIOT/blob/master/drivers/srf04/srf04.c#L53">https://github.com/RIOT-OS/RIOT/blob/master/drivers/srf04/srf04.c#L53</a><br>
    </p>
    <p>[1]
<a class="moz-txt-link-freetext" href="https://github.com/RIOT-OS/RIOT/blob/master/drivers/srf04/include/srf04_params.h#L34">https://github.com/RIOT-OS/RIOT/blob/master/drivers/srf04/include/srf04_params.h#L34</a><br>
      [2]
<a class="moz-txt-link-freetext" href="https://github.com/RIOT-OS/RIOT/blob/master/boards/common/arduino-atmega/include/arduino_pinmap.h">https://github.com/RIOT-OS/RIOT/blob/master/boards/common/arduino-atmega/include/arduino_pinmap.h</a></p>
    <p><br>
    </p>
    <div class="moz-cite-prefix">Am 28.03.2019 um 11:50 schrieb lefteris
      mourelatos:<br>
    </div>
    <blockquote type="cite"
cite="mid:VI1PR09MB25093A637D8ABDFDED7FF235EB590@VI1PR09MB2509.eurprd09.prod.outlook.com">
      <meta http-equiv="Content-Type" content="text/html;
        charset=ISO-8859-7">
      <style type="text/css" style="display:none;"> P {margin-top:0;margin-bottom:0;} </style>
      <div style="font-family: Calibri, Helvetica, sans-serif;
        font-size: 12pt; color: rgb(0, 0, 0);">
        Hello,</div>
      <div style="font-family: Calibri, Helvetica, sans-serif;
        font-size: 12pt; color: rgb(0, 0, 0);">
        I am currently trying the srf04 test and i constantly have the
        same error "Error initializing".I did some digging but i can't
        find any solution to this problem.I am using an arduino-uno for
        this task.</div>
      <div style="font-family: Calibri, Helvetica, sans-serif;
        font-size: 12pt; color: rgb(0, 0, 0);">
        Thank you in advance!</div>
      <br>
      <fieldset class="mimeAttachmentHeader"></fieldset>
      <pre class="moz-quote-pre" wrap="">_______________________________________________
users mailing list
<a class="moz-txt-link-abbreviated" href="mailto:users@riot-os.org">users@riot-os.org</a>
<a class="moz-txt-link-freetext" href="https://lists.riot-os.org/mailman/listinfo/users">https://lists.riot-os.org/mailman/listinfo/users</a>
</pre>
    </blockquote>
  </body>
</html>